Your app hasn't made enough calls to the Graph API to show any info for the methods you selected

0 nhận xét

Summary:

Your app hasn't made enough calls to the Graph API to show any info for the methods you selected between v2.3 and v2.9 occur when i have a notification :Reminder: Graph API v2.3 will be deprecated on July 10, 2017. Please use the API Upgrade Tool to understand how this might impact your app. For more details see the changelog.

Your app hasn’t made enough calls to the Graph API to show any info, or there are no changes for the methods you selected between v2.3 and v2.9.

Solution

Facebook said:
The alert you have received mentions that your app is still using v2.0 API calls. Due to the way platform related web requests are logged on our side, this may include uses of the Login Dialog if it was invoked without an explicit version in the URL.

If your app's minimum API version is v2.1 or above (you can verify this in the app settings "Dashboard" page), you don't need to do anything, and you can ignore this alert.
If your app's minimum API version is v2.0, we recommend that you vet your app's code and look for Platform Integrations (API calls) that explicitly use v2.0. You can then proceed to upgrade those. If you are certain that you are not using v2.0, you can also ignore this alert.

Since you should not be blocked by this issue, I am now closing this bug report.

Another question:

Our app recently got this alert message

- our app -  has been making recent API calls to Graph API v2.0, which will reach the end of the 2-year deprecation window on Monday, August 8, 2016. Please migrate all calls to v2.1 or higher in order to avoid potential broken experiences.

We recommend using our new Graph API Upgrade Tool to see which of your calls are affected by this change as well as any replacement calls in newer versions. You can also use our changelog to see the full list of changes.

but we don't use 2.0 call

our iOS client is using "2.3" ( FBSDK_TARGET_PLATFORM_VERSION is 2.3)
and our Android client is using "2.4"  (ServerProtocol.GRAPH_API_VERSION is 2.4)
and our Server is using "2.2" ( FacebookRequest.php 's GRAPH_API_VERSION is 2.2)
Facebook said:
This appears be a valid bug, and I am assigning this to the appropriate team.
Facebook Comments
Blogger Comments
Share knowledge

Copyright © 2016 - Share knowledge ®