The image part with relationship ID rId9 was not found in the file

Description: The image part with relationship ID rId9 was found in the file. Images in presentation disappear - and are replaced with 'The image part with relationship ID rId2 was not found in the file'

This error occur with the  .docx, .pptx when  copy and paste images from other documents as normally , the images go missing with a frame and the information mentioned in it is "the image part with relationship ID rId9 was found in the file" or "the image part with relationship ID rId6 was found in the file" or "the image part with relationship ID rId1 was found in the file" for various types of images. saving as PDF still image missing. In power point,  Images in presentation disappear - and are replaced with 'The image part with relationship ID rId2 was not found in the file'
The image part with relationship ID rId9 was found in the file
There is no definitive fix yet.  There are some partial fixes:
- switch (Save As) to PPT format from PPTX
- disable all automated backup to cloud tools
If you want to save to internet / cloud, do it manually until the fix is released.
That's an incredibly long thread (some 42 pages of stuff). The short version is more or less:

Right off:

Don't open files into PPT from DropBox, OneDrive or any other similar locations. Copy them to your hard drive, in a folder that is NOT synched, and open/save there.

Next:

Apply available updates to PowerPoint. You don't mention which version of PPT you have; specific instructions for this will vary. MS may not have totally eliminated this problem, but they've definitely got it on the run.

Another from microsoft:
It would be helpful if you can upload a sample file (images / word doc on a common FTP site like sky drive) so that we can test the same.
After reading through your post, I feel that the cause of the issue might be file corruption (Document / images that are inserted)

From where do you copy the picture and paste?

Create a local copy of the picture and save it on the computer; try inserting the image in the other word document and check if the issue persists.